Совместимость ELMA 3.6 и MSSQL SERVER 2014

Для успешной работы с ELMA 3.6 с использованием MSSQL SERVER 2014 необходимо создать базу данных с режимом совместимости MSSQL SERVER 2012 (Compability Level). Для этого необходимо выполнить следующие действия:

  1. Начать создание новой базы данных (рис. 1).

Рис. 1. Создание новой базы данных в MSSQL SERVER 2014

2. Перейти в параметры и выбрать уровень совместимости SQL Server 2012 (110) (рис. 2).

Рис. 2. Выбор уровня совместимости

Если база данных была уже создана, уровень совместимости можно изменить двумя способами:

  • изменить уровень совместимости в аспектах базы данных;
  • выполнить запрос в базу данных.

Изменение уровня совместимости в аспектах базы данных

Чтобы изменить уровень совместимости у уже созданной базы данных, необходимо выполнить следующие действия:

  1. Нажать правой кнопкой мыши на базу данных и выбрать пункт Аспекты (рис. 3).

Рис. 3. Выбор Аспектов созданной базы данных

2. Выбрать Параметры базы данных из выпадающего списка поля Аспект (рис. 4).

Рис. 4. Выбор Аспекта "Параметры базы данных"

3. В появившемся окне найти поле CompabilityLevel и из выпадающего списка выбрать Version110 (рис. 5).

Рис. 5. Выбор уровня совместимости в "Параметрах базы данных"

4. Нажать ОК.

Выполнение запроса в базу данных

Для изменения уровня совместимости у уже созданной базы данных можно выполнить запрос.

Для этого необходимо:

  1. Нажать правой кнопкой мыши на созданную базу данных и выбрать пункт меню Создать запрос (рис. 6).

Рис. 6. Выбор пункта "Создать запрос"

2. Написать запрос:

ALTER DATABASE database_name

SET COMPATIBILITY_LEVEL = 110

где database_name – имя вашей базы данных.

Нажать кнопку Выполнить (рис. 7).

Рис. 7. Выполнение запроса